I recently started using swig to create jni wrappers around some legacy c code. One of the functions thats being wrapped has a function with a variable named class, so the function call looks similar to DO_FOO(FooClass class, Bar bar); the FooClass class is causing me some problems in
1.3.27 it generates a java class with a variable named class. Is there a way to have swig change the name of this variable so that it isn't a java keyword? I tried %rename and %name and neither seemed to do the trick. Any suggestions?